Ergebnis 1 bis 11 von 11

Thema: XML-Änderung unwirksam

  1. #1
    Registrierter Benutzer
    Registriert seit
    29.09.13
    Beiträge
    7

    XML-Änderung unwirksam

    Hallo allerseits,

    ich habe, leider erfolglos, versucht die Spielgeschwindigkeit in gamespeedinfo.xml gemäß anleitung anzupassen.
    Gewünschtes Ergebnis: 1 Monat je Runde bei gleichbleibendem Spielende.

    in der xml sieht das wie folgt aus:

    gamespeed normal
    .
    .
    .
    MonthIncrement: 1
    TurnsPerIncrement: 3600

    Leider werden diese Änderungen im Spiel nicht wirksam.

    Chache wurde geleert
    Das Spiel deinstalliert und alle Restdateien beseitigt.
    Neuinstallation mit und ohne offiziellem Patch

    Ich nutze WinVista und habe die XML mit "XML-Notepad 2007" bearbeitet.

    Hat jemand eine Idee, was ich noch vergessen haben könnte?

    Grüße
    Jerry

  2. #2
    Col-Modder Avatar von raystuttgart
    Registriert seit
    19.03.10
    Ort
    Stuttgart
    Beiträge
    4.530
    Du hast aber schon auch ein neues Spiel gestartet ?

    Oder hast du versucht ein altes Savegame zu laden ?
    (Savegames speichern solche Einstellungen mit.)
    Teammitgleid dieses Projekt für Colonization:
    [Mod] We The People
    (Nachfolgerprojekt von Religion and Revolution)

    Davor Teammitgleid dieses Projekt für Colonization:
    [Mod] Religion and Revolution

    Vor-Vorheriges Projekt für Colonization:
    [ModMod] ray's Wunschliste

    Und wiederum davor Teammitglied von:
    [Mod] The Authentic Colonization (TAC)

  3. #3
    Registrierter Benutzer
    Registriert seit
    29.09.13
    Beiträge
    7
    Selbstverständlich ;-)

    Hatte dann probehalber die settings bei "Marathon" auch angepasst und jeweils (nach jeder installation) ein spiel "normal" & "marathon" als szenario oder zufallskarte neu gestartet.

    Die Datumsanzeige bei "normal" zeigt auch nur das Jahr, keine Monate an.

  4. #4
    Registrierter Benutzer Avatar von Ramkhamhaeng
    Registriert seit
    19.07.10
    Ort
    Aralkum
    Beiträge
    8.942
    Hast du TAC installiert, aber dann die XML-Datei vom normalen Col geändert?

  5. #5
    Registrierter Benutzer
    Registriert seit
    29.09.13
    Beiträge
    7
    Auch das leider nicht. Nutze das Spiel derzeit noch "blanko"

  6. #6
    hat den Blues Avatar von Elwood
    Registriert seit
    05.11.07
    Beiträge
    4.352
    Macht vielleicht die Nutzerkontensteuerung trouble? Dass du Dateien als Nutzer veränderst, aber das ganze als Admin installiert hast oder so ähnlich?
    Geschichten zum Lesen ...

    Der seltsame Fall des William Penn | Col II --- TaC-Mod | abgebrochen
    Wahnsinn mit Methode? | Col II --- TaC-Mod | beendet | SdM April 2012
    Visiting Vvardenfell | TES III Morrowind | pausiert
    Es war einmal (noch) kein Portugal | Civ IV --- PAE-Mod | beendet
    Pack die Thermohose ein ... | Icewind Dale --- Trials of the Luremaster | läuft
    NEU: [RL] ... wie Gott nach Frankreich - Elwoods ??? | Modellbaubericht | läuft

  7. #7
    Registrierter Benutzer
    Registriert seit
    29.09.13
    Beiträge
    7
    Hmm, in die Richtung tüftel ich nachher mal ein wenig, obwohl ich eigentlich alles über ein und denselben Account bearbeite.

    Sollte ich dann aber nicht schon beim Speichervorgang Probleme bekommen?
    Denn die Änderungen werden in der XML ja übernommen.

  8. #8
    Registrierter Benutzer
    Registriert seit
    29.09.13
    Beiträge
    7
    Habe den xml-editor jetzt mit administratorrechten gestartet und offenbar lag es auch daran.

    Allerdings baut mir der editor jetzt in die erste zeile nach: "xml-version= 1.0" einen kommentar "encoding= utf-8" ein, welcher sich auch nicht entfernen lässt.
    Dadurch wird die xml vom spiel als beschädigt betrachtet es lässt sich keine partie eröffnen.

  9. #9
    Col-Modder Avatar von raystuttgart
    Registriert seit
    19.03.10
    Ort
    Stuttgart
    Beiträge
    4.530
    Nimm doch einfach Notepad++ um die XML zu bearbeiten.
    (Nutzen die meisten von uns Moddern und ist kostenlos.)
    Teammitgleid dieses Projekt für Colonization:
    [Mod] We The People
    (Nachfolgerprojekt von Religion and Revolution)

    Davor Teammitgleid dieses Projekt für Colonization:
    [Mod] Religion and Revolution

    Vor-Vorheriges Projekt für Colonization:
    [ModMod] ray's Wunschliste

    Und wiederum davor Teammitglied von:
    [Mod] The Authentic Colonization (TAC)

  10. #10
    Talking Bull Avatar von Writing Bull
    Registriert seit
    01.10.08
    Beiträge
    21.488
    Zitat Zitat von JerryU Beitrag anzeigen
    Habe den xml-editor jetzt mit administratorrechten gestartet und offenbar lag es auch daran.
    Verstehe ich dich richtig, dass du im Kontextmenü dieser XML-Datei auf den Befehl "öffnen" und nicht auf den Befehl "bearbeiten" gehst? Falls ich das richtig verstanden habe, dann schaue doch bitte mal in den Anfang des unten eingebetteten Tutorialvideos rein. Da zeige ich beispielhaft, wie man Colonization-Dateien mit einem Texteditor bearbeitet.



  11. #11
    Registrierter Benutzer
    Registriert seit
    29.09.13
    Beiträge
    7
    Es lag wohl eher am schlechten editor ... MS-Produkt eben ;-) ... hab jetzt nen anderen genommen und es läuft.

    Danke für die Hilfe

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •